import re
regex = re.compile(r"^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$", flags=re.MULTILINE)
test_str = ("3.14529\n"
"-255.34\n"
"128\n"
"1.9e10\n"
"123,340.00\n"
"720p")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")