re = /^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$/m
str = '3.14529
-255.34
128
1.9e10
123,340.00
720p'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end