import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+?.\\d+) oz|Ounce";
final String string = "0 Adult Dog Food 18-Count, 3.5 oz Pouches 3.5\n"
+ "1 Gardetto’s Snack Mix, 1.75 Ounce 1.75\n"
+ "2 Colgate Whitening Toothpaste, 3 oz Tube 3\n"
+ "3 Adult Dog Food, 13.2 oz. Cans 24 Pack 13.2\n"
+ "4 Keratin Hair Spray 2!6 oz 6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}