import re
regex = re.compile(r"(\d+?.\d+) oz|Ounce", flags=re.MULTILINE)
test_str = ("0 Adult Dog Food 18-Count, 3.5 oz Pouches 3.5\n"
"1 Gardetto’s Snack Mix, 1.75 Ounce 1.75\n"
"2 Colgate Whitening Toothpaste, 3 oz Tube 3\n"
"3 Adult Dog Food, 13.2 oz. Cans 24 Pack 13.2\n"
"4 Keratin Hair Spray 2!6 oz 6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")