const regex = /^([\w+-.])+@([\w-.])+.([A-Za-z]{2,64})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w+-.])+@([\\w-.])+.([A-Za-z]{2,64})$', 'i')
const str = `test@example.email`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}