const regex = /([^.]{3})(?=(?:.\.[^.]*){2}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^.]{3})(?=(?:.\\.[^.]*){2}$)', 'gm')
const str = `aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}