re = /([^.]{3})(?=(?:.\.[^.]*){2}$)/m
str = 'aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end