using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/([\w]+[.])*google[.]com";
string input = @"https://as2df.google.com
https://fasd.af.sdfa.google.com
https://fsda21.sdfa.dfas.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}