$re = '/https:\/\/([\w]+[.])*google[.]com/m';
$str = 'https://as2df.google.com
https://fasd.af.sdfa.google.com
https://fsda21.sdfa.dfas.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);