$re = '/^(?=(?:.*\p{L}){4})(?=(?:.*\p{N}){2})(?=(?:.*\p{P}){2}).{8,}$/m';
$str = 'abcd12.-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);