re = /^(?=(?:.*\p{L}){4})(?=(?:.*\p{N}){2})(?=(?:.*\p{P}){2}).{8,}$/m
str = 'abcd12.-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end