use strict;
my $str = 'https://d2ynliea65eb6o.cloudfront.net/6100052500-STXMLOPEN/sub_1.m3u8
https://d2ynliea65eb6o.cloudfront.net/6100052499-STXMLOPEN/sub_1.m3u8
https://d2ynliea65eb6o.cloudfront.net/6100052498-STXMLOPEN/sub_1.m3u8';
my $regex = qr~([^/\n]+)/(?=[^/\n]+$)~mp;
my $subst = '$1/$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";