$re = '~([^/\n]+)/(?=[^/\n]+$)~m';
$str = 'https://d2ynliea65eb6o.cloudfront.net/6100052500-STXMLOPEN/sub_1.m3u8
https://d2ynliea65eb6o.cloudfront.net/6100052499-STXMLOPEN/sub_1.m3u8
https://d2ynliea65eb6o.cloudfront.net/6100052498-STXMLOPEN/sub_1.m3u8';
$subst = "$1/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;