package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^"]+?)(".*?"|$)`)
var str = `Lorem ipsum "dolor" sit amet, consectetur "adipiscing" elit.
Nunc ultrices varius odio, "ut accumsan nisi" aliquet vitae.
"Ut faucibus augue tortor, at aliquam purus dignissim eget." abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}