re = /([^"]+?)(".*?"|$)/
str = 'Lorem ipsum "dolor" sit amet, consectetur "adipiscing" elit.
Nunc ultrices varius odio, "ut accumsan nisi" aliquet vitae.
"Ut faucibus augue tortor, at aliquam purus dignissim eget." abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end