const regex = new RegExp('^((\\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$', 'gm')
const str = `+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}