re = /^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$/m
str = '+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end