using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-z0-9 ]+)|([?,.!:\'\""=_\-%#@\&\])([a-zA-z0-9 ]|$)";
string input = @"Hello!Friend of my friend ... how are you! I'm tired, don ' t I! Two differences: one, two , three,four, five! !Hey!Hey =) How are you?
Oh , we've got plenty of time . __eou__ We haven't . Hurry up ! __eou__ All right.Let ' s go . __eou__ And about time too . __eou__
line: What dressing would you like on the salad ? __eou__ French dressing , please . __eou__ I beg your pardon ? __eou__ Oh , French dressing . __eou__ Sorry , it's not available now.Anything else ? __eou__ We still prefer French dressing . __eou__ Will you say it again ? __eou__ Who's your manager ? Tell me ! Would you ? __eou__
line: Excuse me , can I use your computer to type my paper ? __eou__ No problem . __eou__ I am afraid I can't finish typing it this afternoon.When will you use it tonight ? __eou__ Oh , Never mind , I finished my paper.So you can use it tonight . __eou__ Thanks a lot ! __eou__";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}