use strict;
my $str = 'Hello!Friend of my friend ... how are you! I\'m tired, don \' t I! Two differences: one, two , three,four, five! !Hey!Hey =) How are you?
Oh , we\'ve got plenty of time . __eou__ We haven\'t . Hurry up ! __eou__ All right.Let \' s go . __eou__ And about time too . __eou__
line: What dressing would you like on the salad ? __eou__ French dressing , please . __eou__ I beg your pardon ? __eou__ Oh , French dressing . __eou__ Sorry , it\'s not available now.Anything else ? __eou__ We still prefer French dressing . __eou__ Will you say it again ? __eou__ Who\'s your manager ? Tell me ! Would you ? __eou__
line: Excuse me , can I use your computer to type my paper ? __eou__ No problem . __eou__ I am afraid I can\'t finish typing it this afternoon.When will you use it tonight ? __eou__ Oh , Never mind , I finished my paper.So you can use it tonight . __eou__ Thanks a lot ! __eou__';
my $regex = qr/([a-zA-z0-9 ]+)|([?,.!:\'\"=_\-%#@\&\])([a-zA-z0-9 ]|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}