#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+):(\d+):(\d+):\s(\w\d+)\s(.+)$"
Local $sString = "> Executing task: ament_flake8 src/ <" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"src/examples/rclpy/actions/minimal_action_client/examples_rclpy_minimal_action_client/client_cancel.py:38:5: E303 too many blank lines (2)" & @CRLF & _
" def goal_response_callback(self, future):" & @CRLF & _
" ^" & @CRLF & _
"" & @CRLF & _
"src/examples/rclpy/actions/minimal_action_client/examples_rclpy_minimal_action_client/client_cancel.py:52:5: E303 too many blank lines (2)" & @CRLF & _
" def feedback_callback(self, feedback):" & @CRLF & _
" ^" & @CRLF & _
"" & @CRLF & _
"2 E303 too many blank lines (2)" & @CRLF & _
"" & @CRLF & _
"61 files checked" & @CRLF & _
"2 errors" & @CRLF & _
"" & @CRLF & _
"'E'-type errors: 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")