import re
regex = re.compile(r"^(.+):(\d+):(\d+):\s(\w\d+)\s(.+)$", flags=re.MULTILINE)
test_str = ("> Executing task: ament_flake8 src/ <\n\n\n"
"src/examples/rclpy/actions/minimal_action_client/examples_rclpy_minimal_action_client/client_cancel.py:38:5: E303 too many blank lines (2)\n"
" def goal_response_callback(self, future):\n"
" ^\n\n"
"src/examples/rclpy/actions/minimal_action_client/examples_rclpy_minimal_action_client/client_cancel.py:52:5: E303 too many blank lines (2)\n"
" def feedback_callback(self, feedback):\n"
" ^\n\n"
"2 E303 too many blank lines (2)\n\n"
"61 files checked\n"
"2 errors\n\n"
"'E'-type errors: 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")