package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?github\.com\/(?<author>[\w-]+)\/(?<repo>[\w-]+)\/?(tree\/)?(?<branch>[\w-]+)?`)
var str = `https://github.com/richardwilkes/gcs/tree/master`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}