$re = '/^(Advogado\:\s)(.+?)(Número\sdo\sProcesso\:\s)(.+?)(OutroCampo\:\s)(.+?)$/m';
$str = 'Advogado: XXXXX Número do Processo: XXXXXX OutroCampo: XXXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);