package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)<!--.*?-->(*SKIP)(*F)|</entity>`)
var str = `.........
........
<entity>
.......
.......
</entity>
........
........
<!--
.......
<entity>
........
</entity>
.......
.......
-->
<entity>
.......
........
</entity>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}