re = /(?s)<!--.*?-->(*SKIP)(*F)|<\/entity>/m
str = '.........
........
<entity>
.......
.......
</entity>
........
........
<!--
.......
<entity>
........
</entity>
.......
.......
-->
<entity>
.......
........
</entity>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end