using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w.-]+);([A-Za-z]\w*=\w+(?:,[A-Za-z]\w*=\w+)*)$";
string input = @"blahblahblah;first=1,second=two
bl.hbl-hbl_hbl4hbl4h;first=1,second=two,third=thr33,fourth=4th
bl.hbl-hbl_hbl4hbl4h;first=1,ssssssssss";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}