package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w.-]+);([A-Za-z]\w*=\w+(?:,[A-Za-z]\w*=\w+)*)$`)
var str = `blahblahblah;first=1,second=two
bl.hbl-hbl_hbl4hbl4h;first=1,second=two,third=thr33,fourth=4th
bl.hbl-hbl_hbl4hbl4h;first=1,ssssssssss`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}