package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+49\d{9,}|0)$`)
var str = `+49123456789
0
00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}