$re = '@^(?:\+49\d{9,}|0)$@m';
$str = '+49123456789
0
00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);