#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^upload/(?<header>[a-z-]+/[a-z0-9-\.]+)/(?<class>\d*+[a-z0-9_.]+(?>/\d*+[a-z0-9_.]+)*)/(?<id_table>\d+)/(?<id_external>\d+/)?(?<entity>[a-z0-9-_]+)(/\w+)?\.(?<ext>\w+)$"
Local $sString = "upload/image/jpeg/.tables/.user/1/2/avatar/small.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")