use strict;
my $str = 'upload/image/jpeg/.tables/.user/1/2/avatar/small.jpg';
my $regex = qr~^upload/(?<header>[a-z-]+/[a-z0-9-\.]+)/(?<class>\d*+[a-z0-9_.]+(?>/\d*+[a-z0-9_.]+)*)/(?<id_table>\d+)/(?<id_external>\d+/)?(?<entity>[a-z0-9-_]+)(/\w+)?\.(?<ext>\w+)$~p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}