#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Level>(\d+)<\/tank"
Local $sString = "This XML file does not appear to have any style information associated with it. The document tree is shown below." & @CRLF & _
"<seqSmartbox xmlns="http://tecson.dev.oilview.de/gateway/xsd" xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance" xsi:schemaLocation="http://tecson.dev.oilview.de/gateway/xsd/smartbox.xsd">" & @CRLF & _
"<seqHeader>" & @CRLF & _
"<indication>Manuelle Abfrage</indication>" & @CRLF & _
"<authCode>03B41236A899</authCode>" & @CRLF & _
"<devOperator/>" & @CRLF & _
"<devLocation/>" & @CRLF & _
"<devID>2-852</devID>" & @CRLF & _
"<devVersion>V6.02</devVersion>" & @CRLF & _
"</seqHeader>" & @CRLF & _
"<seqData>" & @CRLF & _
"<seqTanks>" & @CRLF & _
"<tankNumber>1</tankNumber>" & @CRLF & _
"<tankName>Heizöl</tankName>" & @CRLF & _
"<seqTankLevel>" & @CRLF & _
"<tankLevel>490</tankLevel>" & @CRLF & _
"<tankUnit>L</tankUnit>" & @CRLF & _
"</seqTankLevel>" & @CRLF & _
"<tankPercent>5</tankPercent>" & @CRLF & _
"<seqTankSize>" & @CRLF & _
"<tankSize>10000</tankSize>" & @CRLF & _
"<tankUnit>L</tankUnit>" & @CRLF & _
"</seqTankSize>" & @CRLF & _
"<seqTankClear>" & @CRLF & _
"<tankClearance>9010</tankClearance>" & @CRLF & _
"<tankUnit>L</tankUnit>" & @CRLF & _
"</seqTankClear>" & @CRLF & _
"</seqTanks>" & @CRLF & _
"</seqData>" & @CRLF & _
"<seqPara>" & @CRLF & _
"<para1>30</para1>" & @CRLF & _
"<para2>15</para2>" & @CRLF & _
"<para4>0</para4>" & @CRLF & _
"<para5>5</para5>" & @CRLF & _
"<para9>0</para9>" & @CRLF & _
"</seqPara>" & @CRLF & _
"</seqSmartbox>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")