# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Level>(\d+)<\/tank"
test_str = ("This XML file does not appear to have any style information associated with it. The document tree is shown below.\n"
"<seqSmartbox xmlns=\"http://tecson.dev.oilview.de/gateway/xsd\" xmlns:xsi=\"http://www.w3.org/2000/10/XMLSchema-instance\" xsi:schemaLocation=\"http://tecson.dev.oilview.de/gateway/xsd/smartbox.xsd\">\n"
"<seqHeader>\n"
"<indication>Manuelle Abfrage</indication>\n"
"<authCode>03B41236A899</authCode>\n"
"<devOperator/>\n"
"<devLocation/>\n"
"<devID>2-852</devID>\n"
"<devVersion>V6.02</devVersion>\n"
"</seqHeader>\n"
"<seqData>\n"
"<seqTanks>\n"
"<tankNumber>1</tankNumber>\n"
"<tankName>Heizöl</tankName>\n"
"<seqTankLevel>\n"
"<tankLevel>490</tankLevel>\n"
"<tankUnit>L</tankUnit>\n"
"</seqTankLevel>\n"
"<tankPercent>5</tankPercent>\n"
"<seqTankSize>\n"
"<tankSize>10000</tankSize>\n"
"<tankUnit>L</tankUnit>\n"
"</seqTankSize>\n"
"<seqTankClear>\n"
"<tankClearance>9010</tankClearance>\n"
"<tankUnit>L</tankUnit>\n"
"</seqTankClear>\n"
"</seqTanks>\n"
"</seqData>\n"
"<seqPara>\n"
"<para1>30</para1>\n"
"<para2>15</para2>\n"
"<para4>0</para4>\n"
"<para5>5</para5>\n"
"<para9>0</para9>\n"
"</seqPara>\n"
"</seqSmartbox>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.