$re = '/^.*[a-zA-Z]+.*\..*[a-zA-Z]+.*\..*(~|\-|\+)*[a-zA-Z0-9]+$/m';
$str = '//good
1c.1c.0
v1c.1.asdf
errhand.LSD.asdf+dfsg
1.c1.asdf
c1.1.asdf
c1c.1.asdf
1.c1cc.asadf~dsf
//bad
1.1
1.1.1
1.00.00
v1c.1.
1.v1c.
1.01.01~sdgf
1.v1c.asdf-sadf+asdf
~1c.1c.0
1c.1~c.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);