package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((.*?)\)\sstarted playing\s(.*?)( - (.*?))?\.`)
var str = `hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Trolls Band Together.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}