const regex = /\((.*?)\)\sstarted playing\s(.*?)( - (.*?))?\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*?)\\)\\sstarted playing\\s(.*?)( - (.*?))?\\.', 'gm')
const str = `hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Trolls Band Together.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}