package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:sum\(|count\(|avg\()([\w|(|_|+|\-|*|\/|.|'|[|\]|||]*)`)
var str = `sum((a+b)*c)+count((a*c)+b)+avg((a-c)/b)+sum((a-c+d)/b)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}