// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:sum\(|count\(|avg\()([\w|(|_|+|\-|*|\/|.|'|[|\]|||]*)").unwrap();
let string = "sum((a+b)*c)+count((a*c)+b)+avg((a-c)/b)+sum((a-c+d)/b)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}