using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/locations\/[^\/]*(\/[a-zA-Z0-9-?=#_]*)";
string input = @"https://myfrontend.com/locations/usa/remaining-url?a=1#
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}