re = /\/locations\/[^\/]*(\/[a-zA-Z0-9-?=#_]*)/
str = 'https://myfrontend.com/locations/usa/remaining-url?a=1#
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end