use strict;
my $str = 'www.example.com is a cool website';
my $regex = qr/(?:[a-z]+:\/\/)?(?:[a-z\d-]+\.)+(?:a(?:ero|rpa)|biz|co(?:m|op)|edu|gov|in(?:ternal|fo|t)|jobs|m(?:il|useum)|n(?:a(?:me|to)|et)|org|pro|travel|local|[a-z]{2})(?::\d{1,5})?(?:\/[\w.~-]+)*(?:\/[\w.-]*(?:\?[\w+.%=&;-]*)?)?(?:#[\w!$&'()*+.=~:@\/?-]*)?(?!\S)/ip;
my $subst = '<a href="$&">$&</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";