$re = '/(?:[a-z]+:\/\/)?(?:[a-z\d-]+\.)+(?:a(?:ero|rpa)|biz|co(?:m|op)|edu|gov|in(?:ternal|fo|t)|jobs|m(?:il|useum)|n(?:a(?:me|to)|et)|org|pro|travel|local|[a-z]{2})(?::\d{1,5})?(?:\/[\w.~-]+)*(?:\/[\w.-]*(?:\?[\w+.%=&;-]*)?)?(?:#[\w!$&\'()*+.=~:@\/?-]*)?(?!\S)/i';
$str = 'www.example.com is a cool website';
$subst = "<a href=\"$&\">$&</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;