package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(.*myword.*\)`)
var str = `(random text myword)
(random text myword random text)
(myword random text)
(myword, random text)
(random text, myword random text)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}