$re = '/\(.*myword.*\)/m';
$str = '(random text myword)
(random text myword random text)
(myword random text)
(myword, random text)
(random text, myword random text)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);