#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([^(]*myword[^)]*\)"
Local $sString = "(random text myword)" & @CRLF & _
"(random text myword random text)" & @CRLF & _
"(myword random text)" & @CRLF & _
"(myword, random text)" & @CRLF & _
"(random text, myword random text)" & @CRLF & _
"(random text) random text (random text myword) random text (random text)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")