re = /\([^(]*myword[^)]*\)/m
str = '(random text myword)
(random text myword random text)
(myword random text)
(myword, random text)
(random text, myword random text)
(random text) random text (random text myword) random text (random text)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end