import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(public\\s*class\\s*(\\S*)\\s*\\{.*?(?:\\}(?=\\s*(?:(?:public\\s*class)|$))))";
final String string = "public class Abc\n"
+ "{\n"
+ " ...\n"
+ "{}\n"
+ "{{}}\n"
+ "}\n\n"
+ "public class Xyz\n"
+ "{\n"
+ "{}{}\n"
+ "{{}{}}\n"
+ " ...\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}