$re = '/(public\s*class\s*(\S*)\s*\{.*?(?:\}(?=\s*(?:(?:public\s*class)|$))))/s';
$str = 'public class Abc
{
...
{}
{{}}
}
public class Xyz
{
{}{}
{{}{}}
...
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);