package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<td><a [^>]+?>(.*?)</a></td>`)
var str = `<td><a class="x">1</a></td>
<td><a class="y">2</a></td>
<td><a class="z">3</a></td>
`
var substitution = "<td>$1</td>"
fmt.Println(re.ReplaceAllString(str, substitution))
}