$re = '~<td><a [^>]+?>(.*?)</a></td>~m';
$str = '<td><a class="x">1</a></td>
<td><a class="y">2</a></td>
<td><a class="z">3</a></td>
';
$subst = "<td>$1</td>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;